Bug 95 - The compiler-rt library is built with the wrong compiler configuration.
Summary: The compiler-rt library is built with the wrong compiler configuration.
Status: RESOLVED INVALID
Alias: None
Product: ELLCC
Classification: Unclassified
Component: libecc (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- major
Assignee: Richard Pennington
URL:
Depends on:
Blocks:
 
Reported: 2014-11-11 06:33 CST by Richard Pennington
Modified: 2017-07-29 16:21 CDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Pennington 2014-11-11 06:33:31 CST
There is a bug in how libecc is made. Specifically in the build rules for compiler-rt. Currently compiler-rt is built using the default compiler options in libecc/mkscripts/targets/<target>/setup.mk. These make scripts are obsolete and should be replaced with an appropriate target configuration from libecc/config. All of the other libraries are built with the right config, but unfortunately compiler-rt has a pretty complicated build script and I haven't gotten around to figuring out how to fix it. The ELLCC specific compiler-rt build script is in libecc/src/compiler-rt/make/platform/ellcc_linux.mk.
Comment 1 Richard Pennington 2017-07-24 06:50:14 CDT
Resolved as WONTFIX during bug database cleanup.
Comment 2 Richard Pennington 2017-07-29 10:36:18 CDT
These bugs are obsolete with the new build and deployment process.
Comment 3 Richard Pennington 2017-07-29 10:37:33 CDT
These bugs are obsolete with the new build and deployment process.
Comment 4 Richard Pennington 2017-07-29 10:39:08 CDT
These bugs are obsolete with the new build and deployment process.
Comment 5 Richard Pennington 2017-07-29 10:42:11 CDT
These bugs are obsolete with the new build and deployment process.